1C -code

Пишем после Процедуры ОбработкаПроведения() функцию

Функция УбратьПробелы(Наим)
Поиск=Наим;
н=0;Рез=»»;
Пока Найти(Поиск,» «)>0 цикл
Поз=Найти(Поиск,» «);
Слово=Лев(Поиск,(Поз-1));
ОстальнаяЧасть=Прав(Поиск,(СтрДлина(Поиск)-Поз));
Поиск=ОстальнаяЧасть;
н=н+1;
Рез=Рез+Слово;
КонецЦикла;
ПоследнееСлово=Поиск;
Результат=Рез+ПоследнееСлово;
Возврат(Результат);
КонецФункции

 

Если ЭтотОбъект.ВидДоговора=Перечисления.ВидыДоговоровКонтрагентов.СПокупателем
тогда
Сообщить(«Это таки договор лизинга»);
Попытка
Запрос=Новый Запрос;
Запрос.Текст=»ВЫБРАТЬ
|     ДоговорыКонтрагентов.Наименование
|ИЗ
|     Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов;

Выбока=Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() цикл
НаименованиеСЗапроса=УбратьПробелы(СокрЛП(Выборка.Наименование));
НашеНаименование=УбратьПробелы(СокрЛП(Наименование));

Если НаименованиеСЗапроса=НашеНаименование тогда
Сообщить(«Уже существует такой договор!»);
Отказ=Истина;
КонецЕсли;

КонецЦикла;

Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
//////////////////////////////////////////////////////////////////////
Функция УбратьПробелы(Наим)
Поиск=Наим;
н=0;Рез=»»;
Пока Найти(Поиск,» «)>0 цикл
Поз=Найти(Поиск,» «);
Слово=Лев(Поиск,(Поз-1));
ОстальнаяЧасть=Прав(Поиск,(СтрДлина(Поиск)-Поз));
Поиск=ОстальнаяЧасть;
н=н+1;
Рез=Рез+Слово;
КонецЦикла;
ПоследнееСлово=Поиск;
Результат=Рез+ПоследнееСлово;
Возврат(Результат);
КонецФункции

//
//проверка на Наименование

Если ЭтотОбъект.ВидДоговора=Перечисления.ВидыДоговоровКонтрагентов.СПокупателем
тогда
Сообщить(«Это таки договор лизинга»);
Попытка
Запрос=Новый Запрос;
Запрос.Текст=»ВЫБРАТЬ
|    ДоговорыКонтрагентов.Наименование
|ИЗ
|    Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
|Где
|Наименование =&Наим»;
Запрос.УстановитьПараметр(«Наим»,Наименование);
Если  НЕ Запрос.Выполнить().Пустой() Тогда
Сообщить(«Уже существует такой договор!»);
Отказ=Истина;
КонецЕсли;
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;КонецЕсли;

в процедуре ОбработкаПроведения()

Если ЭтотОбъект.ЭтоНовый() тогда
Спр=Справочники.ДоговорыКонтрагентов.Выбрать();
НаименованиеНовогоДокумента=УбратьПробелы(СокрЛП(ЭтотОбъект.Наименование));
Пока Спр.Следующий()цикл
ПеребраныеНаименования=УбратьПробелы(СокрЛП(Спр.Наименование));
Если НаименованиеНовогоДокумента=ПеребраныеНаименования тогда
Сообщить(«Такой договор существует»);
Отказ=Истина;
Конецесли;
КонецЦикла;
КОнецЕСли;

Если ЭтотОбъект.ЭтоНовый() тогда
Спр=.ДоговорыКонтрагентов.Выбрать();
НаименованиеНовогоДокумента=УбратьПробелы(СокрЛП(ЭтотОбъект.Наименование));
Пока Спр.Следующий()цикл
ПеребраныеНаименования=УбратьПробелы(СокрЛП(Спр.Наименование));
Если НаименованиеНовогоДокумента=ПеребраныеНаименования тогда
Сообщить(«Такой договор существует»);
Отказ=Истина;
Конецесли;
КонецЦикла;
КОнецЕСли;

Реклама

Добавить комментарий

Заполните поля или щелкните по значку, чтобы оставить свой комментарий:

Логотип WordPress.com

Для комментария используется ваша учётная запись WordPress.com. Выход / Изменить )

Фотография Twitter

Для комментария используется ваша учётная запись Twitter. Выход / Изменить )

Фотография Facebook

Для комментария используется ваша учётная запись Facebook. Выход / Изменить )

Google+ photo

Для комментария используется ваша учётная запись Google+. Выход / Изменить )

Connecting to %s